PFZ.nl - PHP Community: Compatibiliteitsweergave in IE - Frontend - Forum - PFZ.nl - PHP Community

Je kunt niet antwoorden op dit topic
#1 16-03-2011 08:03
In de nieuwere internetexplorers is onder Extra een mogelijkheid om de Compatibiliteitsweergave aan te zetten. Ik weet niet precies hoe het werkt, maar het zou oudere sites met een verouderde frontend toch goed kunnen weergeven in de nieuwe IE9 bv.
Mijn nieuwe site voldoet aan alle W3C W3css wensen, maar met die Compatibiliteitsweergave aan gebeuren er gekke dingen: een deel van het submenu valt ineens weg. Rara....
Mijn vraag is: kun je met een verborgen php-opdracht zorgen dat die Compatibiliteitsweergave niet kan worden aangezet, of die automagisch uitzetten?
Wie heeft een idee?

#2 16-03-2011 08:16
  • AScripter
  • Groep: Forumleden
  • Posts: 76
  • Actief sinds: 04-03-2005
Kort door de bocht: Nee, dat kan niet.
Het kapitaal van een onderneming wordt niet bepaald door de prachtige produkten of fantastische dienstverlening, het kapitaal van een onderneming wordt bepaald door de mensen die deze onderneming maken. - (Jan-Willem Koppers)

#3 16-03-2011 08:37
Dat is wel heel kort door de bocht ja. Weet je toevallig of er een referentiesite is waar je kunt checken wat die knop Compatibiliteitsweergave voor effect heeft op je site en wat er aan te doen is? Je kunt anderen niet dwingen Firefox te gebruiken, dus ja...

#4 16-03-2011 09:14
  • Gary vd H
  • Groep: Forumleden
  • Posts: 1084
  • Actief sinds: 26-01-2005
Conditional comments voor oudere IE browsers gebruiken?

#5 16-03-2011 19:22
  • Martin P
  • Groep: Moderators
  • Posts: 6284
  • Actief sinds: 19-04-2007

Bekijk Post Op 16-03-2011 09:03 schreef Roel Toering:

Mijn vraag is: kun je met een verborgen php-opdracht zorgen dat die Compatibiliteitsweergave niet kan worden aangezet, of die automagisch uitzetten?
Nee, PHP is serverside en een browser is nog steeds clientside ;)

Bekijk Post Op 16-03-2011 09:37 schreef Roel Toering:

Weet je toevallig of er een referentiesite is waar je kunt checken wat die knop Compatibiliteitsweergave voor effect heeft op je site en wat er aan te doen is?
Je kunt met een meta-tag toch afdwingen dat IE in de nieuwste modus draait? Hier kun je daarover lezen.
Hiermee draai je IE altijd in de nieuwste modus die beschikbaar is op de betreffende computer:
1
<meta http-equiv="X-UA-Compatible" content="IE=Edge" />

Bij Gmail doen ze met javascript een check en detecteren ze dat IE in compatibiliteitsmodus draait. Dit wordt ook een beetje uitgelegd op de genoemde site. Javascript zou wel mijn laatste keuze zijn, want je wil natuurlijk een oplossing hebben die altijd werkt.

Bekijk Post Op 16-03-2011 10:14 schreef Gary vd H:

Conditional comments voor oudere IE browsers gebruiken?
Dat is sowieso iets dat je gebruikt, maar met conditional comments kun je niet een compatibiliteitsweergave van IE detecteren. Met conditional comments kun je enkel IE-versies detecteren, niet hoe ze ingesteld staan.
Handleidingen zijn er niet voor niets, gebruik ze dus :)
HTML5 ~ CSS ~ PHP ~ MySQL ~ SQL-injectie bestaat al sinds 1998

#6 18-03-2011 14:47
  • Taco V
  • Groep: Moderators
  • Posts: 850
  • Actief sinds: 12-08-2008
Ik verplaats dit naar Frontend.


Inloggen wachtwoord vergeten? Aanmelden